Welcome, Guest. Please Login or Register.
07.02.23 at 03:20:13
Home All forum attachments and linked/autosaved images Help Search Login Register Sprache umschalten für Gäste

Pages: 1
Send Topic Print
Low compression on XV920 (Read 6512 times)
Michael Warner(Guest)
Ex Member



Low compression on XV920
04.07.01 at 22:46:00
 
I recently purchased an XV920 that is not running well.  It is VERY low on power, and I am getting only 110 PSI compression on the back cylinder and 120 on the front.  The bike only has about 20,000 miles on it and is not burning any oil.  Any ideas?

 
 
Top of page
  IP Logged
Erik Steen(Guest)
Ex Member



Low compression on XV920
Reply #1 - 05.09.01 at 12:54:00
 
Hi Michael
I had a bike like that, a 1982J model, some of the 920´s had bad camshafts, you can remove them without take the engine apart, if the loope is not shiny then it is worn and won´t lift the valve very much.
Hi from Erik

 
 
Top of page
  IP Logged
Iain MacPherson(Guest)
Ex Member



Low compression on XV920
Reply #2 - 15.09.01 at 03:24:00
 
try making sure that the valves are not too tight then do a dry compression test then a little oil and another compression test which will determine whether it is the pistons and/or rings or valves that are at fault.

 
 
Top of page
  IP Logged
Big Scott(Guest)
Ex Member



Low compression on XV920
Reply #3 - 16.03.02 at 17:21:00
 
Chances are ,The front head gasket has blown!! Because the engine hangs from the front pot!

 
 
Top of page
  IP Logged
Pages: 1
Send Topic Print